読者です 読者をやめる 読者になる 読者になる

パルカワ2

PerlとRubyとイチャラブ

Plaggerのインストールしてみる。

追記:マージされたので今は普通に入ると思います。
https://github.com/miyagawa/plagger/pull/10


懐かしのPlaggerをいれようとしてみたらコケた。

Bareword "use_test_base" not allowed while "strict subs" in use at Makefile.PL line 114

こういうのModule::Install使ってた頃よくあったよなーーーって懐かしい気持ちになりながら、use_test_baseで探して見たら、Module::Install::TestBaseというのがあるらしい。Test::Baseに入っていたそうだけど、最近切りだされたようです。

0.85 Mon Aug 18 08:07:52 PDT 2014
 - Pull Module::Install::TestBase out of Test::Base

なので、

cpanm Module::Install::TestBase

してからやると通る。

Perlやり始めた時Plaggerを読むと良いという話を聞いた。
結局使うこともインストールもしなかったけど、今になってインストールやプルリクをすることになるとは思わなかった………。