パルカワ2

PerlとRubyとイチャラブ

Google Pixel3 を交換する 2

そんなことある?って感じなのだけどまた壊れたので問い合わせた。
いろいろ質問されて最終的にまた交換することになった。すぐ交換してもらえるのはありがたいが壊れないでほしい。

今回も前回同様にPixel Phone Helpからチャットで問い合わせている。

以下を伝えると迅速だろうなと思ったので、次回参考にする。(次回はないほうが嬉しい)

## どのような症状が起きているか?

## 症状の動画などのURL

## その症状は、いつから起きているか?

## この症状が発生する直前に起きた出来事(水没・落としたなど)

## 今の端末で出来ること・出来ないこと

## 画面に保護カバーは貼っているか?

## 端末の再起動をしたか?

## 端末のファクトリーリセットを行ったか?

## 問い合わせ前、他に行ったことはあるか?

交換することが決まったら、端末IDを聞かれる。端末IDは、箱かSIMカード取り出し口か購入時のメールに記載されている。端末が操作できる場合は、設定からも見れるぽい。僕はメールを見た。
また1度でも交換したことがある場合は交換したことがあることを伝えて、端末IDを答えると相手が手間取らないのでよい。

前回
hisaichi5518.hatenablog.jp

日本人の勝算を読んだ

日本人の勝算: 人口減少×高齢化×資本主義

日本人の勝算: 人口減少×高齢化×資本主義

積んでた本読んでる。結構雑に読んだ。
日本の人口は減少する→人口が減るということは、規模の小さい企業には雇える人がいなくなる→企業統合などによって企業は大きくなっていく必要がある→大きくなるには生産性を高める必要がある→生産性を高めるには、最低賃金をあげる→他にも生産性を高めるには教育が必要という話だった。

一生楽しく浪費するためのお金の話を読んだ

一生楽しく浪費するためのお金の話

一生楽しく浪費するためのお金の話

知ってるけどめんどくてやってないことなのでちゃんとやるか…みたいな気持ちになった。

最近Spotifyしか使ってない

これの続き
hisaichi5518.hatenablog.jp

Youtube Premium と Apple Music と Spotify に課金をしているんだけど、最近はSpotifyだけ使うようになってきた。ただApple Musicにもまだ課金しているんだけどそろそろ解約すると思う。
Youtube Premium についてくる Youtube Music や Google Play Music は使ってないけどYoutubeの広告が消えるのは便利なので課金している。

Spotifyは、他の端末で再生している音楽をMacから変更できるというのが大きい。

f:id:hisaichi5518:20190630150245p:plain
こんな感じで下にPixel 3で再生中と出ているときは変更できる

Android以外でも変更は出来て、例えばGoogle Home miniとかで再生していても変更できる。仕事場に着いたらAirPodsiMacに接続し直すみたいなのがなくて便利。

Apple Musicは、For youタブにあるFriend MIXが面白い。SpotifyにもDesktop版にはありそうなんだけどMobile版にはないみたい。

[Mobile] Friends Feed on Mobile - The Spotify Community

Flutter+Android Studio 3.4.1 で Adaptive icons が設定できない

iOSでつくったものをAndroidで作り始めると「マジめんどいので共通化したい」という気持ちが芽生えるので、やりはじめた。 www.appbrewery.co

こういう環境でやっている。

Android Studio 3.4.1
Build #AI-183.6156.11.34.5522156, built on May 2, 2019
JRE: 1.8.0_152-release-1343-b01 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.5

「How to Add App Icons to the iOS and Android Projects」を見ていてAndroidのAdaptive icons対応するところで、 android/app/src/main/res を右クリックして、 New > Image Assets を選んだらええで!って言われたけど、Project must be built with SDK 26 or later to use adaptive icons と言われてNextが押せない。SDKが26未満なの〜?マジ〜?と思って確認してみたところ、28を使っているので問題ないようだった。

f:id:hisaichi5518:20190621225356p:plain なんかよくわからないけどAndroid Studioが認識出来ていないのかなーと思って、build.gradleを編集しているときに右上に出ているOpen for Editing in Android Studioをクリックして、androidディレクトリをAndroid StudioをNew Windowで開き、再度同じ手順でやったら出来た。 f:id:hisaichi5518:20190621225351p:plain

Jestを使うことにした

Jest · 🃏 Delightful JavaScript Testing

  • ユニットテスト書きたい
  • DOM操作があるテストができる
  • 通信の処理があるのでモックとかもしたい
  • 導入がめんどくさくない

自分でkarma/jasmineの設定もしてみて先人の知恵のおかげで困りはしなかったんだけど、まあJestでええか…みたいな感じになった。